Surface and Orbit Authority

Stuck grids & fixes

Last night, @Canderthal noted that any time he attempted to weld a specific grid he was working on, he immediately got kicked from the server. After investigating, I found no evidence in the logs to explain why that was happening, but could see him getting logged out every time he touched it.

As the grid in question is quite large, and as “game bugs” are not in the category of interesting gameplay constraints, I opted to use the Space Master’s admin tools to fix the problem by removing the grid and pasting it back in place. Normally, this would be something that requires notice, but as the change is small (one grid, moved about 20m in the process of fixing a game bug) and highly localized, I went ahead without giving notice. If anyone feels strongly that I should not do that, I’ll accept that; the process for sanctioning me isn’t hard.

Removing and re-pasting the grid worked, astonishingly.

Thanks again for that!

I have no objections to this having been done.

I certainly have no issue with the Space Master doing something minimally invasive like this, at the request of the grid owner. My only concern would be if there’s potential for a player to use this to “get one up on” someone else, but I have a hard time imagining a scenario where that would be a real issue.

Edit: I’m amazed but happy it worked!

No objections here. I am glad it worked out as well.

I have been mulling over a couple of ideas around the notion of ‘Emergency Server Status’. I don’t know if our current situation exactly fits that description, but it made me start thinking. (new thread incoming)

1 Like

It happened again this evening.

A project I was working on was afflicted by the “weld this grid and get disconnected” problem last night, so I took the opportunity to experiment a little bit to explore how the game behaves in this situation. I discovered two things that appear to be repeatable.

  1. If you encounter a grid that causes disconnects when you weld it, odds are good it’s a grid that has a projection attached to it. In both my case and @Canderthal’s case, the grid itself came from a projection loaded in earlier.
  2. If you turn the projector off and manually place a block, that block can be welded. Once you do - whether you leave the new block in place or not - if you turn the projector back on, you will not disconnect from the server when welding the grid.

This appears to be a less-intrusive workaround. I’m still trying to figure out what causes this - it happened to me twice last night on the same project, so it’s not exactly rare, and @Canderthal reported it several times on his project. If you run across it and figure out what’s causing it, please share your discoveries. If we can get this sorted out or reduce it to something appropriate for a bug report, all the better.

I ran into it the other day when I was working on my new miner from a projection.

Before it crashed me I noticed that some of the ghost blocks were glitched. I had the materials for that block and i had the projector in the mode that only shows blocks that can be added. When I tried to weld it, nothing would happen. It seems like some kind of desync situation. I remember the block was a battery.